Bug-Lag when usign encoders on Hoglet

Hello everybody, i recently upgraded my Hogon PC to 3.14 and I´m facing a strange behaviour after a while. When scrolling through  (a list or the output for example) by using Open+EncoderWheel (for up/down), the list doesn´t move along with turning the encoder. The scrolling just stops, and after a second or so it moves again. Same is happening, when I want to adjust Pan/Tilt for example.

At first, I thought, it would be in context with the network. I used a laptop with an own superwidget for Backup. Hog-/Fixturenet have their own NICs with different IP ranges, so both nets are separatet. PC with Hoglet had its four universes to ArtNet as well (there was no output on ArtNet). When having turned of the PC with Hoglet, everything went fine for a while, then the upper behaviour came up again. Didn´t have any problems with further versions

Specs of PC with Hoglet: Core i3 8100, 8 Gb RAM, 120 Gb SSD, 27" Multitouch (USB). Hoglet is the first series, it was bought in December 2016. I THINK its version is 2.3, but I am not sure.

Could it be that the patched ArtNet universes cause trouble, when they are not in use? I have to admit that in further versions I had not enabled any DMX-output over network, when having not used it

  • *Update 2020-11-04: problem appeared again. No Fixture-Net was patched. Lagging when scrolling through lists, etc. seems to be fixable by restarting the desktop-process (haven´t tried when setting Pan/Tilt).
    No reports or logs were generated (as far as I have seen).
    Version of Hoglet: 1247-2.3(1,0)
    Version of External Widget: 12264--4.1(0,0)
  • On your PC, can you send me a screen shot of a few places? 

    • PC Specification,

      • System info (press windows key and type system info)

    • Hog 4 PC Control panel

    • System info tab

      • Hognet Tab 

    • Fixturenet tab

    • Processor settings(In the network window)

      • Output tab (If on 3.14.0)

    • sACN output HogNet traffic requires a network link that allows for Multi-cast traffic.

    • ArtNet output (If on 3.13.1 and below)

    Can you attach your show file with steps on how to get the lag to happen?

  • Hello Noah, I will do that today afternoon (Germany). I switched back to 3.13.1, I experienced this lag once. I cannot say how to securely reproduce it, but I think that it is likely to happen, when buttons like Open, Clear or Choose arepressed rapidly behind each other. But this may be just a subjective opinion.
  • Hello Noah, show file and Fotos were sent to you.
  • *Update 2020-12-05: Bug also happens with 3.12. Complete re-installation of dedicated pc for Hoglet didn´t work. Bug didn´t vanish. It doesn´t only happen with the buttons mentioned in the earlier post.
    BUT: the bug is traveling with the hoglet. I tried a different computer (with 3.14), and there I can provoke the bug within five minutes or so.
    I have to admit that when you turn the encoder wheels very slowly after the bug "happened", you can still get smooth pan/tilt movements or whatever you do with the wheels. But due to the fact that i do a lot of busking and not knowing exactly when it happens, it bothers me a lot.
    Were there any firmware-updates for the hoglet in versions after 3.12?
  • *Update 2020-12-07: it seems that the bug is gone with a freshly installed Win10 Build 1909. Tested on 3.14.
  • Same problem here. Check it on a desktop pc, a laptop an a NUC. PC is a powerful machine (I7, 64gb ram, M2 HDD, 1060Ti ) Laptop (I7, 16gb ram. SSD) NUC is a hog dedicated (I7, 16gb ram. SSD). The encoders seems to freeze especially at pan/tilt and focus/zoom functions. Check it with different show files, older and fresh ones and also new show.
    Would like to avoid to reinstall windows. Too much trouble...
  • I am having the "same" issue. That is, when I used the physical encoder wheels on the Hoglet 4, the display on my monitor lags (as do the physical fixture) 1-3 seconds. It can reproduce it with a simple intensity change on a fixture. It started for me with widows update March 9, KB000802, OS Build 19041.867 and 19042.867. I am on Windows 20H2 OS Build 19042.867 When I back out that update, the issue goes away.

    The computer system is dedicated to only this application, nvidia graphics card, significant memory, etc.. All USB are directly into the computer.

    I am running HOG 3.15.0 (b.3121)

    I backed out that windows update and the issue went away so it certainly appears to be related to that update.
  • @TGP: I am not sure about that specific update since i already had the problem in the beginning of december 2020 on two different machines. I am currently running 3.15.0 on a Win10 1909 with all security patches installed, no problems. When switching to a laptop with up-to-date 20H2, the bug is there again. But I´m happy for you that you can work again :)
  • I have Same Problem.
    Have tried 3 different PC'S all with I7 windows 10 and desired specs as hog requires. Fresh install only works for a few minutes sometimes hours before the problem starts again.
    Using a nano hog4.
    Found running and effect then fanning example pan or tilt attribute really aggravates the lag to 3 seconds.