Novation Launchpad mini MK3


Anyone who tried hooking up a Launchpad mini MK3 to a roadhog? Seems to detect the unit, but no midi coming in..


  • This is not a device that I have tested, or honestly heard of before, so my knowledge of it is based off of the manual.

    One thing is I noticed that the device needs to be connected to a computer to be configured, but I am not sure that this step doesn't also install drivers on the computer for this device to operate.  If drivers need to be installed on a computer to use the device, this device won't work on Hog 4 consoles. If the device is showing up in the Console Settings MIDI Configuration tab in the Network Window, that is a good sign that is isn't a concern.

    Looking at the manual, the device needs to be in Custom mode, and it needs to have MIDI Notes configured there from Novation's software. I am not sure if you have performed this step.

    Once the device is able to generate MIDI Notes, then you should be able work along with Chapter 21.2 of the Hog 4 OS manual (linked below) to configure which MIDI Notes trigger what functions on the console.  You will need to be using v3.15.0 or newer for these steps to work.

  • yes. i can confirm it works. However i cant tell you details right now because i left mine at a venue and i have to pick it up next week :(.  But i have tried this succesfully already. 

  • Hey fritskefruitig,

    I feel your MIDI pain, friend. I've battled with the Launchpad mini MK3 and some stubborn systems too. First off, make sure your Launchpad is in the right mode – sometimes it plays hard to get. Switch between Live and User modes, see if that gets the MIDI flowing.

    Check your MIDI settings on the Roadhog, too. It can be a finicky beast. Confirm that the Launchpad is recognized in your MIDI devices. If not, you might need to install or update drivers.

    If you're still stuck, here's a trick from my playbook: try a different USB port or cable. Sometimes, it's the simple things that trip us up.

    Oh, and update the firmware on your Launchpad if you haven't. Software gets grumpy when it's outdated.

    Hit me up if you need more help – been there, done that.