Thunderbolt Docks can crash any EOS Primary/Backup by being left on but disconnected

This has happened to me before but I've never been able to figure out exactly what was going on, until this week. I have a Thunderbolt 3 dock for my laptop for the production desk with its own power supply and a NIC.

When I disconnect the Thunderbolt cable from my laptop at the end of the day, after it has been a client all day, after some period of time the EOS primary totally locks up (both interface and output), sometimes also showing the Windows "This application has stopped responding" dialog.

This problem seems to be unique to Thunderbolt docks because they can stay powered on with the NIC active even when there is no computer connected, as opposed to USB C dongles that lose power when they are disconnected from the laptop.

As soon as I unplug the ethernet cable from the back of the dock, EOS immediately begins to respond again. I have seen this behaviour on multiple systems with different brands of Thunderbolt dock.

I need to test next week whether this only happens when the laptop has recently been a Client. The rest of the network functions correctly, I can still log into my managed switches etc, which makes me think that this is an EOS specific thing rather than a network-level thing (eg the thunderbolt dock causing a network storm).

Perhaps EOS has an infinite timeout waiting for the client to respond if the NIC is up but the laptop is no longer connected? Or something along those lines?

  • Hi   would you please collect logs from the Eos Primary so that we can have a look, along with a couple of dates/times for us to look at?  That may help guide us to what is going on.

    You can email them directly to me at mattp@etcconnect.com, or post them here if you prefer.

    One thing that springs to mind - is the Eos Primary set to use the Mac (or some other external device) as its Show Archive?  We have seen instances where having a remote Show Archive that leaves the network caused Windows or Eos to hang.

  • Hi Matt, I’ll try and make it happen tomorrow and will send the logs. Not using the Mac as the show archive though, just a client.