Very, very basic Lua Script trigger question...

Hi everyone!

I always thought I know my way around various programming and scripting languages but I can't seem to get even the most simple Lua script off the ground...

To get started I want to simply trigger a timeline at StartUp.

What I did:

-  Set trigger to "StartUp"

-  Set trigger's "Action" to "Run Script"

-  Make "New Script"

-  Use script "get_timeline(2):start()" to start timeline 2

-  Press "Build" to compile the code

I try to simulate the project - no result

I upload to the project to the Mosaic controller - no result

What am I missing? A special Lua script firmware uploaded to the controller? I read through several Lua trigger documents on ETC's web-site but nothing mentions anything special.

How can I get this simple one line script off the ground?

Thank you for your help in advance,

Erwin

Parents
  • Make sure the “New Script” is associated with the startup trigger.

    Do the logs show the script is attempting to run?  You may need to increase the log level.

    Test your script with a new Soft Trigger and fire from the web interface.  Does it run then?  Logs?

Reply
  • Make sure the “New Script” is associated with the startup trigger.

    Do the logs show the script is attempting to run?  You may need to increase the log level.

    Test your script with a new Soft Trigger and fire from the web interface.  Does it run then?  Logs?

Children
  • Yes the "New Script" is associated with the startup trigger

    I made a new Soft Trigger and initiated it from the web interface. Same nil result. Log states the same as before:

    "ACTION Run Script: Failed to run script [string "script"]:1: attempt to call a nil value (global 'get_timelime')"

Related