CS 40 AV looses IP connection

I'm trying to send cue change messages via OSC from QLab to the CS console - which works like a charm.

But after some time (between 30 and 60 minutes) the console does not respond to OSC messages anymore and can't be pinged as well.

Un- and replugging the ethernet kable or changing the IP address of the console make it again accessable via OSC.

Does anybody have a hint on why this happens? I've changed the ethernet cable so far and tried other IP addresses and/or ports without any luck...


  • I would start by noting what the LEDs at the CS 40's network jack look like when working properly, and if those change when you notice that OSC messages and Ping no longer work.  Also, take note of what the LEDs on your network switch are doing, as well as the device sending ping / OSC.  Do those change when this happens?

    My guess is that your network switch may time out somehow, but that does seem strange.

  • Matt, thanks for your answer and suggestions! I'll have a look at the LEDs on console and switch when back in the theatre. A time out of the switch doesn't make much sense, as other devices connected to the same switch (QLab and sound desk) continue to exchange OSC messages.

    I'm a freelancer for this theatre and the sound guy (I only have basic knowledge about lighting... ;-) but I wonder whether this could be due to an IP address conflict. I do not know if the fix IP address of the console is within the range of DHCP - could it be that any other device is "stealing" it's address via the DHCP server?

  • A properly-configured DHCP server won't hand out duplicate IP addresses.  However, if you're setting a static IP address on the ColorSource, the DHCP server can't prevent that.  Having a duplicate IP address can cause all sorts of odd behaviors.

    ColorSource AV has a Web interface (called Amigo) - you could try keeping that open, to see if that makes any difference. 

    Lastly, the next time this happens, before fixing the issue, could you please: 
    - save the console logs to a USB thumbdrive
    - fix the problem (unplug / replug the Ethernet cable)
    - save the console logs again

    Then you should be able to post both sets of logs here or email me directly at mattp at etcconnect.com

  • Problem solved! It turned out that in fact it was an IP address conflict: The CS console was registered in the router with a fix IP address, but in the console's setup there was a different address. Nobody was aware of this, as it is the first time the console is triggered via OSC from an external source.
    Changing the address in the console to match the one registered in the router did the trick - everything runs smooth now!
    Thanks Matt for your help and support - appreciate it very much!