OSC filter

Does the OSC filter work? Tried following, but nothing happens. What is wrong?

6 Replies - Page 1 of 1

  • Have you tried sending the filter before the fader config command? (Also, are you sure you don't want to get the fader names as you map a bank of faders? :) )
  • In reply to Hans.Hinrichsen:

    I've send the filter after sending the fader config. Will try to do it before.
  • In reply to sstaub:

    No change, it makes no difference if I send the message before or after the fader config message.
  • I may be mistaken, but I think the filter works in the opposite direction. Adding a filter results in only those messages you've specified. So by adding a filter "/eos/out/*" you're essentially asking eos to send only messages that start with /eos/out/.
  • In reply to KCrayn:

    I thought that was the subscribe function!?
  • In reply to sstaub:

    Yeah it's a bit weird, but based on the #lightbox box_1 it would seem that the filter does work in the opposite direction.

    It has the following lines:

     

    // Add a filter so we don't get spammed with unwanted OSC messages from Eos
    OSCMessage filter("/eos/filter/add");
    filter.add("/eos/out/param/*");


    Which seems to suggest that it filters out everything but /eos/out/param/* as it needs /eos/out/param/pan and /tilt.

    My guess is the subscribe function tells Eos to send a message whenever the subscribed parameter changes, where the filter stops it sending other messages.

Page 1 of 1
Related