Insight 1 and ETCedit

I've been running an Insight 1 this summer. I got the ETCedit software but have been having trouble with it not reading the disk or not being able to save the show file. I've looked into it a little bit and it seems like I'm not the only one who has had this trouble in the past. I was wondering if anyone has found a work around that could possibly help.


Thank you.


  • Hi Aaron,

    I am going to start with the obvious, are you using DSDD floppies?  The Insight 1 uses DSDD floppies.  If you are trying to use DSHD floppies, they may work if you tape over the hole on the side of the disk.  DSDD floppies are hard to come by these days.  I purchased a box about 4 years ago, when I found some just to have them in case I ran into an old desk.

    Now, the problems that I have experienced in the past were when the floppies were either formatted on the computer or fresh out of the box as formatted disks.  What I have found to work is to format the floppy on the light board and then use the disk with ETCEdit to save the file onto it.  Remember that there can only be one file on the floppy, and it doesn't want to have any system files saved on it.

    Hope that helps,



  • Hi John.

    Thanks for the response.

    I have been using the Double Density disks. They work fine in the board and then when I try them on my computer, no luck.

    I've also tried formatting them on the board as well and that hasn't worked either.

Reply Children
No Data