How to prevent luminosus from freezing? Or is there a setting or something I have incorrect?

I've a project file setup that uses a faderbank block mapped to a MIDI controller. Fairly often Luminosus will freeze requiring me to restart ETCnomad and Luminosus. I can restart on my laptop when at home pretty easily, but when I use it during a live performance that would not be acceptable. I usually find that the last thing I was doing before Luminosus freezes is adjusting faders on the MIDI controller.

I've checked that I have the correct settings enabled in the EOS software to allow luminosus to work:

I'm using EOS 2.9.1
EOS has String Rx and Tx enabled
EOS has OSC Rx and Tx enabled
EOS has OSC TCP format for OSC 1.0 (setting in the ETCnomad shell)
EOS and Luminosus have the same IP address for the lighting board (I update this when I'm programming at home or when I'm at the venue where I load the show file to a Nomad Puck)

Equipment/software: Luminosus, ETCnomad Puck (ETCnomad offline editor on a laptop), Akai APCmini MIDI controller

Related