Problems updating a Net3 Gateway

We recently had a service visit to upgrade software on our PACP units and the technician spoke to us about using UpdaterAtor to update the firmware in our other networked devices. He didn't have time to update the other devices while he was here.

So, today I tried to update two of the Net3 four port gateways, the update download into the gateway took more than an hour, then when the gateway rebooted, it was still on the original software version. Something isn't working with the updates. We haven't updated for quite some time since we normally didn't have any down-time during the year. But due to covid we have time for side projects like this now.

The Net3 Gateways in our system are running

Is there a process for getting these Gateways to v7 software? UpdaterAtor doesn't allow for download of version 5 software. I attempted to do the version but I got the same result.

It seems that it downloads the update and reboots, but doesn't actually do the update on the Gateways.

Any ideas?