Response MIDI gateway network problem

I have a brand new Response MIDI gateway that was working properly on arrival and has now stopped working over the network. It won't receive an IP address over DHCP (other devices on the network will), and if I configure an IP manually on it, it won't respond to pings or show up in Concert.

All of this was working when I first set it up. It worked straight out of the box, grabbed an IP address from my DHCP server and was sending MIDI TC to devices on the network just fine.

I've tried changing the network cable, restarting the gateway, and restoring the default settings in the menu - nothing helps.

It's really frustrating as it was working just fine out of the box - this issue only came up after I accidentally had the device plugged in by ethernet with PoE, and by USB at the same time. I'm worried that I may have damaged the device somehow by doing this, but it seems unlikely. Any suggestions would be greatly appreciated - otherwise I'll call tech support on Monday.