Keyboard Layout on PC Forced to Qwerty on Eos Open

Hi there,

My computer's default keyboard layout is not Qwerty, but when I open Eos in 3.1.2 b15, it resets the current layout to Qwerty. Easy to change back in the moment, but it continually throws me off right now. 

I haven't noticed it until b15, but it could have happened before.

I'm on a Windows 11 PC.

Thanks!

Parents
  • Ok, I looked deeper on macOS. The keyboard layout settings in ECU affect only the virtual keyboard and doesn't affect the hardware keyboard which is assigned by the OS. Don't know if this is a bug or by system.

  • Hi  and  , we made a change in 3.1.2  that is mentioned in the Build Report:

    EOS-53397 Win10: non-QWERTY keyboard is reverted to QWERTY after power cycle

     It forces the keyboard layout that is selected in Shell>Settings each time Eos software is started.

    However, as you say, this may be undesireable on ETCnomad where the user has access to their own computer's keyboard layout tools.  So, we've changed the logic to only do this on consoles, not on PC / Mac.  

Reply
  • Hi  and  , we made a change in 3.1.2  that is mentioned in the Build Report:

    EOS-53397 Win10: non-QWERTY keyboard is reverted to QWERTY after power cycle

     It forces the keyboard layout that is selected in Shell>Settings each time Eos software is started.

    However, as you say, this may be undesireable on ETCnomad where the user has access to their own computer's keyboard layout tools.  So, we've changed the logic to only do this on consoles, not on PC / Mac.  

Children