“Move Dark” no longer works correctly in v3.0.0.33

Hi all, I’m wondering if anyone else is having the same problem:  

I’m running a rig with 4 small moving light fixtures (MARTIN Mac 250 Entour). “Move Dark” previously seemed to work correctly; the console would first “fade” the fixtures to 0 intensity and then, once at 0, would “move dark” to the next beam and position parameter.

After software update to v3, the console now “always” will record beam and position parameters, even if the fixture is not active in the next cue.  You can remedy this by manually turning off the necessary “include options”. However, this is not helpful if you, for example have the following cue sequence:

cue 1 - using fixtures 1&2

cue 2 - using fixtures 3&4

cue 3 - using fixtures 1&2 again

in the above scenario you are not able to turn off “include options”, and fixtures 1&2 will not properly “move dark” during cue 2 (they will transition to cue 3 during fade out of cue 1). I believe this to be a bug in the newest coding.