OSC not working with a direct UDP connection?

Hey guys, just wondering if anyone has any idea of what's happening with my setup.

I have a program that will send out UDP OSC messages (doesn't connect over TCP) to OSCRouter on the same computer to the EOS software that's also on the same computer. This setup works perfectly fine. However, when I try to connect directly from my control software to EOS the OSC does not get processed yet the same commands being sent to OSCRouter are processed by EOS. I am currently downloading Wireshark to see if perhaps the software is spitting out garbage and OSCRouter is spitting out "clean" packets. Anyone got 2 cents they don't mind falling out of their pocket?

  • Grrrr... Wireshark shows that the data that the controller is sending is clean data (according to the OSC protocol). I do have the control software working with the broadcast address as well as using my computer's IP provided by my network's DHCP server... Does EOS ignore stuff on localhost / 127.0.0.1 ? Looks like EOS does NOT bind to localhost and only binds to it's network IP. Atleast now I know that when I take this to my console it'll work just fine, just needs a little help for my pre-show work. I'll just leave this here in case anyone else needs this information :D

  • sending to the correct port?

    what does Eos' diagnostic tab (tab 99) show? (don't forget to enable the logging of incoming OSC in the diagnostic tab itself otherwise you won't see the data listed there)

  • Wireshark was showing "port unreachable" ICMP packets when I tried sending on localhost. It's working now that I tried my network's IP after the success with the broadcast IP.

  • EOS don't use localhost 127.0.0.1, this a very old problem. You need a switch inside the system and you must use the IP address of your EOS system.

Related