High resolution external monitor issues with Nomad

I am sure that I am missing something, but when I use Nomad on a Microsoft Surface with an external monitor attached, EOS on the external monitor is not utilizing the full screen. I do have the high resolution option enabled in the Shell. The display resolutions are 2160x1440 on the Surface display and 2560x1440 on the external monitor (Dell U2520D). If I disable the high resolution option in the Shell, the screen does then get fully utilized but at a seemingly lower resolution (1920x1080 if I were to guess), which leads me to believe that there is a limitation or configuration within EOS as to the max resolution it can drive on the external monitor. What is curious is that when I use a dual monitor setup with a desktop machine both screens are utilizing the higher resolution (ie 2560x1440) and the High Resolution option is selected in the Shell.

Here is an example of the monitor in question when connected to the Surface.

Thanks in advance for any guidance on what I have missed.

Parents
  • Realized that I did not include version information... I am encountering this in 3.0 and 3.0.1.

    Curiously the problem does not manifest itself in 2.9.2, however it seems to work in a manner opposite from what I would have expected. When in Auto mode for the High DPI setting, I get a lower resolution output on the Surface screen and the external monitor shows a constrained EOS window. When in Disabled mode, everything works as expected (high DPI fully utilizing the real estate on both monitors).

    Even more curious is that I do not encounter this on a desktop machine with both monitors at 2560x1440 regardless of the High DPI setting in EOS. Seems like it is something to do with differing resolutions between monitors that is causing a glitch in the 3.0.x code line

Reply
  • Realized that I did not include version information... I am encountering this in 3.0 and 3.0.1.

    Curiously the problem does not manifest itself in 2.9.2, however it seems to work in a manner opposite from what I would have expected. When in Auto mode for the High DPI setting, I get a lower resolution output on the Surface screen and the external monitor shows a constrained EOS window. When in Disabled mode, everything works as expected (high DPI fully utilizing the real estate on both monitors).

    Even more curious is that I do not encounter this on a desktop machine with both monitors at 2560x1440 regardless of the High DPI setting in EOS. Seems like it is something to do with differing resolutions between monitors that is causing a glitch in the 3.0.x code line

Children
  • I'm curious if you are engaging Scaling on the Surface?

    It might be worth playing with that to see if it makes a difference for you.

  • It is using the recommended scaling on both screens (150% on the Surface monitor and 125% on the external). When I change the scaling for the external monitor to 150% it does now fill the screen and appear to be respecting the higher resolution.

    I think this is some kind of bug in the 3.0.x code line since it works properly in 2.9.2 with the same monitor settings (i.e. 150 and 125). Thanks for the thought to check scaling at least I have a workaround for now!

Related