Control EOS with OSC

Hi,

I have a problem with OSC in Eos ETCnomad, I can't send OSC command to eos from touchOSC or Qlab. I have already check IP an RX Port in Eos and the software that send the OSC. I check on my mac with OSC_Data_monitor and the computer receive OSC but not EOS. If someone have an idea to receive OSC in Eos. 

Bonjour, 

J'ai un problème avec Eos ETCnomad. Je n'arrive pas a contrôler EOS avec des command OSC que j'essaye d'envoyer depuis touchOSC ou Qlab. J'ai vérifié mes adresses IP et les port RX et TX qui sont correct. J'utilise aussi OSC_DATA_monitor et mon ordinateur reçois bien les commande osc mais EOS les ignores. Quelqu'un aurait-il une idée de comment réussir à contrôler l'EOS en OSC ? 

VERSION EOS 3.0.2.6

Mac os High-Sierra

  • What's the Eos command you're trying to send?

    Are you using an actual IP or loopback (127.0.0.1)?

  • I using an actual IP 172.20.10.2  and I try several command : 

    /eos/cue/1/30/fire

    /eos/key/6

    /eos/key/delay

    ...

  • There are lots of settings that have to be right for OSC communication.  In the Eos shell> Settings > Network, make sure that "UDP Strings & OSC" is checked for the active/Online network port.  

    Sometimes I mix up the Rx Port and Tx Port in my settings, so I swap them just to make sure that isn't the problem.

    If you open [Tab] + [9] [9] Diagnostics, there are buttons to enable logging of Incoming OSC.  You may wish to enable that and look in that window to see if any messages or errors are reported there.

    Could you clarify, are you using both Eos and TouchOSC/QLab on the same computer, or two different computers, or a computer and a physical console?

  • Thanks for your answer,

    In the Eos shell "UDP Strings & OSC" is check for the online network port.

    I tryed to switch Rx Port and Tx Port in my setting and It still don't work.

    I have already tryed to open the diagnostics Tab. When I enable incoming OSC I see nothing in the window when I send OSC to the EOS ETCnomad.

    I use Eos on my computer an I have TouchOSC on my iPad to send OSC to my computer. Of course I have TouchOSC brige on my computer for receive OSC from my iPad.

    And with TouchOSC I have tried to send OSC in Wifi and in USB, both don't work...

  • Strange.  Since you see the OSC getting to your computer (via OSC Data Monitor) I'm not sure why it doesn't finish getting to the Eos software.  

    One more string to try is 

    /eos/ping

    which should be replied to with 

    /eos/out/ping

    if you have enabled OSC Tx Output, and set an IP address that matches your iPad, the reply should show up there.

  • 1. Are all computers on the same network range and have a static IP?
    2. I there any firewall between?
    3. You can use Wireshark www.wireshark.org to see if there is any network traffic between the computers / console

Related