OSC - subscribe not working reliably

This is really frustrating. It is so complicated to get Pan/Tilt out of EOS.
It would be easy if .. Feature Request to get params
But as it stands the only way is to Subscribe to those parameters, then select a channel in question, then wait for the reply. Correct??

For me this only works if I leave pauses in-between the requests (~0.25sec) and if nothing else keeps EOS busy. As soon as I'm trying to pull Pan/Tilt (from a number of fixtures) while other processes happen, EOS does never reliably reply to all the requests. No matter how long the pauses I leave between those.
Isn't this a bug and can it be fixed?

Is there any other way to pull Pan/Tilt?

Parents
  • Are you trying to get Pan/Tilt values out from record targets? Or from a selected channel in live?

    Most of the OSC hooks are built around two things:

    1. Live values
    2. Record targets

    If you need values from inside a record target, yes, you need to get the channel list then iterate through it, storing the values. There isn't a sync method to go a layer deeper than the record target.

  • Hi Sktusing,

    By record targets you mean Focus Palettes, Cues etc.?
    It's the same to me. I can also set those values before requesting them.

    The iterating-requesting-storing however should still work, even if EOS is doing other things in parallel, right? Or is dropped replies an expected behaviour?

Reply
  • Hi Sktusing,

    By record targets you mean Focus Palettes, Cues etc.?
    It's the same to me. I can also set those values before requesting them.

    The iterating-requesting-storing however should still work, even if EOS is doing other things in parallel, right? Or is dropped replies an expected behaviour?

Children
Related