Unable to get a solid connection with iPhone/iPad iRFR and iOS 5 update.



Since my update to iOS5 I am unable to keep a constant connection to my ION. Every few minutes the app disconnects and I have to reconnect. This problem occurs on both my iPhone 4 and iPad (1st gen). In trying to figure out the problem I noticed that when attempting to connect to the board I would look at the iPhone/seetings/wifi screen and a connection is never truely made. I canstantly see the working icon, never a checkmark. I have asked a couple of other people at the theater with iDevices that have upgraded and they have to same issue trying to connect. I can connect to any other network without any issues except the ION.

I never had this issue until the upgrade to iOS5. If anyone else is having this issue and knows of a solution any help is appreciated.



  • Is your iPad a 3G?

    To trouble-shoot the problem, try switching to Airplane Mode and then connect to your lighting system WAP.




    Dennis Varian

  • hi,

    we have the same problem. the first idea was: no mobile data, but it´s not comfortable...
    Look at the wlan network in your iPhone... what´s your ip?
    DHCP or Statisch?
    You must give the network a static ip... you must write the Router-ip (the same from your WLAN-Router and the DNS (it´s the same ip from your WLAN-Router.
    HTTP-Proxy: AUS (the first button)

    my configuration:

    no Router ip and no DNS ip was our problem.
    Now it works like bevor iOS5 (iPhone 4)

    hope that helps!

  • If there is an iOS 5 issue, I would be very surprised to find it changes any behavior related to the network routing tables. 

    I hate to disagree with theblackmoon but, for the majority of people using iRFR and aRFR there is no reason to do any configuration on your wireless access point/router or to manually set the ip address of the handheld device.  Most problems we see getting iRFR working stem from manually misconfiguring network addresses that the devices can usually get correct on their own. 

    I defined a set of simple steps that work with most wireless routers/access points in this post


    [edited by: Tracy.Fitch at 3:38 PM (GMT -6) on Tue, Oct 18 2011] fixed typo
  • Well, some progress has been made, Thanks Blackmoon, setting it up as static has at least giving me a checkmark in the iphones settings window but I'm still getting constant disconnects. I also tried going into airplane mode but no luck there either. However, the ipad will play nice now after changer over to a static setting, at least it played nice long enough to get me through dimmer check tonight.

    Thanks for everyones suggestions, hopefully I can get this straightened out so both the iPhone and iPad work with the ION network by my next tech.

  • I haven't had any issue with my iPhone running iOS 5, though admittedly I have only used it briefly on two different occasions on two different systems. A co-workers iPhone 4s also connected just fine. I was having some issues with two other iOS devices that were running earlier versions of iOS, but those issues (I believe) were related to an incorrect password set in the iRFR app. (the app would work at first, & then disconnect without any indication that it was the password that was incorrect. After re-entering the password, all was good in the world)
  • I have the same problem. The first time I connected after os5 it was fine now I can't connect. I go into the settings in the app and it sees the console fine have full bars. But it won't connect.  I have checked everything. My iPad is a gen 1 non 3G. 

  • Hi,

    There seems to be a general problem with iOS5 that many iPhone and iPad users have experienced since they upgraded to iOS5. Network connection is frequently dropped. I haven't seen a formal response from Apple yet but I hope they are working to solve this iOS issue.

    [Clarification] Turning on Airplane mode as mentioned before might help as a workaround until it gets fixed since it will make sure that the device is using the network connection and not the cellular one.

    [edited by: Anders Ekvall at 3:32 AM (GMT -6) on Mon, Oct 24 2011]
  • Well, even with airplane mode/non 3g I can't get a good connection. As a test I dug out my old iTouch with the older iOS on it and it worked fine. I'll use the iTouch for now until Apple gets the connection thing sorted out.

  • Howdy Wolf,

    with your iO5 device, can you check what IP the WLAN connection has given your

    iO5 device?



  • Hi Corey,

    auf unsere iPhone´s 4 hat der WLan-Router die IP 192. ... gegeben
    Keine DNS/Router Nummern.
    Der WLan-Router selber arbeitet aber mit /

    vor iOS 5 lief alles super.
    Jetzt haben wir Statische IP mit DNS & Router...  alles ist super. Verbindung stabil!

    Gruß nach Hoki!

  • Sorry for the delay in responding, got caught up in getting a failed Studio Spot fixed.

    My IP is assigned to although sometimes the device changes 108 to 106 (even under static).

    As a test I dug out my iTouch (2nd gen) which I had used before getting an iPhone and iPad. The iTouch is

    running iOS version 4.1 and after updating the iRFR app to it's current version it runs with no issues at all.

    The iTouch IP is I tried to put the wifi setting into the iPhone and iPad and they would not

    connect at all with the iTouch settings. It won't connect at all with the setting that work great in the iTouch.

    Right now the iTouch will work until a solution is figured out but I really miss using the iPads encoder screen. 

  • I'll add a "me too" with having issues. I had originally had many connection issues when running the iOS Beta, but then it resolved itself with the GM release, so I had assumed that it was beta thing. I've now realized that it seems seems to depend on what console / configuration I'm running and the fact that it got better with the GM of iOS was a coincidence. 

    I've now tested my phone on 3 different setups and here is what I get.

    Flakey Connection - Ion running DHCP. Airport Express set to Access Point Mode (just acting as a Bridge). iPhone gets IP from Ion.

    Flakey Connection - Ion running DHCP. Airport Express set to . Phone set to Static IP.

    Good connection - Ion set with Static IP. Airport Express set to Access Point.  iPhone with Static IP.

    Maybe there are other things at fault, but I thought I would mention it just in case.


  • For those who are using iOS 5:

    Could you post to tell us if you are using iCloud and/or Wireless iTunes Sync?

    This is just a general data gathering question and should not be read/implied to represent that there is a known issue with either of those services.

  • I am using iCloud and the wireless sync option. I'll set my iPad up so it is not using those and see what happens tonight.

  • Yes and Yes. iCloud and iTunes Wireless Sync are enabled.